Accordian text coming out plain text
  • Hi
    I just bought and installed the accordian asset.
    I dragged it to a new web page on webplus X8.
    When I publish it exactly like it is it comes up as plain text (i.e. not contractable / expansible).
    What am I doing wrong?! The web page is:
  • Hi Peter,

    Your problem seems to be with your uploading of the site and files, I have just checked to see if everything is in order and when trying to view the CSS file that drives the accordion, I get a 404 error message (page of file not found)

    Doesn't exist, try doing a full upload if your are using webplus, rather than an incremental one as there could also be other things missing which I haven't looked at.

    On closer examination, the css file is on the server but it is in the root folder of the server and not in the sub folder of eft-consultations, hence the code call cant be made correctly.

    If the accordion add-on was directly on a page from and not a sub folder, then it would probably work. So you have 2 options really, adjust the code calls for any files needed for the add-on so they would probably need to start with ../ to call files outside the sub folder or simply upload the accordion files (css & js) to the sub folder of eft-consultations.

    Hope this helps ;-)
  • Thanks so much Mick for your information.
    I installed the new accordian by opening the accordian file from the assets section of Webplus and it added it to the assets section, which meant I could drag it into a web page. Should it not have automatically installed everthing in the right place as part of that?
    Warm regards
  • ..yes you are right - I tried installing it in the root directory and it worked. I would have thought Webplus would have set the right path for the css file if I used a sub-directory.
  • It would do but for some reason, on your upload, things are not being put in the right place on the server and the files for the addon are not being uploaded to the sub folder, no idea why this happening but after looking at your source code of the link you have provided, the html code are all calling webplus files for js and css via an outside folder call, check the code below taken from your link

    <script type="text/javascript" src="../wpscripts/jsNavBarFuncs.js"></script>
    <script type="text/javascript" src="../wpscripts/global_navtree.js"></script>
    <script type="text/javascript" src="../wpscripts/wp_navbar_menub.js"></script>
    <script type="text/javascript" src="../wpscripts/jquery.js"></script>

    So its a webplus/user/upload issue and not actually the addon

    Hope this helps
This discussion has been closed.
All Discussions

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion